Excel Formeln
Excel Hilfe
Excel Makro / VBA
010 Rechts Zahl aus Text separieren

Aufgabe:
Sie haben einen x-beliebigen Text und am Schluss steht ein Zahl, die Sie jeweils extrahieren wollen. Der Text kann dabei mehrere Wörter beinhalten und kann am Schluss eine Zahl haben oder auch nicht.

Formel zum Kopieren:

=WENN((A1="")+ISTFEHL(--RECHTS(GLÄTTEN(A1);1));"";--TEIL(A1;VERWEIS(9;1/(TEIL(A1;SPALTE(1:1);1)=" ");SPALTE(1:1))+1;99))

=IF((A1="")+ISERR(--RIGHT(TRIM(A1);1));"";--MID(A1;LOOKUP(9;1/(MID(A1;COLUMN(1:1);1)=" ");COLUMN(1:1))+1;99))





Ich hoffe, es ist jedem klar, dass die Formel in Zeile 6-8, rsp. 10-12 in nur einer Zelle aneinander geschrieben werden muss. Die Aufsplittung der Formel auf 3 Zeilen erfolgte nur der Leserlichkeit wegen. Aber Sie können ja ohne Problem die ganze Formel wie immer oben direkt in Ihre Excel-Tabelle kopieren.



Excel Formeln
011 Zeit runden