Excel Formeln
Excel Hilfe
Excel Makro / VBA
017 Summe nach Kriterien

Beispiel 1

Sie haben eine Tabelle mit verschiedenen Zahleneinträgen und möchten nur die Zahlen addieren, welche ein bestimmtes Kriterium erfüllen.
In unserem Beispiel sollen alle Beträge addiert werden, welche kleiner (<) grösser (>) 0 (NULL) sind.

Formel zum Kopieren (nach Zelle A10):
=SUMMEWENN(B2:B8;"<>0";A2:A8)
=SUMIF(B2:B8;"<>0";A2:A8)





Beispiel 2

Sie haben Zahlen in einem Bereich (A2:A8) und wollen diese auf Grund eines Kriteriums in einem anderen Bereich (B2:B8), in unserem Beispiel "Schuhe", addieren

Formel zum Kopieren (in Zelle B10):
=SUMMEWENN(B2:B8;"Schuhe";A2:A8)
=SUMIF(B2:B8;"Schuhe";A2:A8)





Beispiel 3

Sie haben eine Tabelle mit verschiedenen Zahleneinträgen mit Posting Key 40 für Soll/Debit und Posting Key 50 für Haben/Credit. Sie möchten nun anhand einer Formel herausfinden, ob Soll und Haben den gleichen Betrag ergeben. Ist dies der Fall, ist das Ergebnis "keine Differenz", anderfalls kommt die Meldung "FALSCH".

Formel zum Kopieren (nach Zelle C9):
=WENN((SUMMEWENN(A2:A7;40;C2:C7))=(SUMMEWENN(A2:A7;50;C2:C7));"keine Differenz";"FALSCH")
=IF((SUMIF(A2:A7;40;C2:C7))=(SUMIF(A2:A7;50;C2:C7));"keine Differenz";"FALSCH")