Excel Formeln
Excel Hilfe
Excel Makro / VBA
015 Zeilennummerierung automatisch

Aufgabe:
Sie wollen eine Tabelle erstellen, die in Spalte A eine automatische, fortlaufende Zeilennummerierung generiert. Dies aber erst, wenn in der entsprechenden Zeile in Spalte B auch ein Eintrag vorhanden ist. Diese Formel ist insofern auch praktisch, dass sich diese beim Löschen von Zeilen automatisch anpasst, so dass Sie immer die richtige, fortlaufende Zeilennummerierung haben.

Formel zum Kopieren (nach Zelle A2):
=WENN(ISTLEER(B2);"";ZEILE()-1)
=IF(ISBLANK(B2);"";ROW()-1)

Hatt die Tabelle keine Titelzeile (Name, Vorname, Ort, etc.), sieht die Formel folgendermassen aus:
=WENN(ISTLEER(B2);"";ZEILE())

=IF(ISBLANK(B2);"";ROW())